OSPF advanced configuration

catalogue

1. Router redistribution and configuration

1.1 route redistribution

Redistribute static route and default route in 1.2 OSPF Protocol

2. Virtual link and its configuration

2.1 virtual link overview

2.1 application occasions and functions of virtual link

2.2 virtual link command

2.3 rules and characteristics of configuring virtual links

2.4 create virtual link and configure bidirectional redistribution and end area

1. Router redistribution and configuration

1.1 route redistribution

Route redistribution is usually configured on routers {that are responsible for learning routes from one AS and then broadcasting to another AS. For example, - routers run both OSPF and RIP. If the OSPF process is configured to announce the routes learned by RIP to OSPFAS, this practice can be called "redistribute RIP"

A single IP routing protocol is the preferred scheme to manage IP routing in the network. Whether from the perspective of configuration management or fault-tolerant management, each router is expected to run a single routing protocol rather than multiple routing protocols. However, in the real network, there are many routing protocols, and if these networks want to interconnect, at least one router must run many routing protocols to realize the communication between different networks. Therefore, the problem of route redistribution is inevitable.

Redistribute static route and default route in 1.2 OSPF Protocol

R1
R1#conf t
R1(config)#int f0/0
R1(config-if)#ip add 10.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#int loop 0
R1(config-if)#ip add 1.1.1.1 255.255.255.255
R1(config-if)#end
R1#conf t
R1(config)#router ospf 110
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 10.1.1.0 0.0.0.255 area 0
R1(config-router)#network 1.1.1.1 0.0.0.0 area 0
R2
R2#conf t
R2(config)#int f0/0
R2(config-if)#ip add 10.1.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#int f1/0
R2(config-if)#ip add 10.1.2.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#int loop 1
R2(config-if)#ip add 2.2.2.2 255.255.255.255
R2(config)#router ospf 110
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0
R2(config-router)#network 10.1.1.0 0.0.0.255 area 0
R2(config-router)#network 10.1.2.0 0.0.0.255 area 0
R3
R3#conf t
R3(config)#int f0/0
R3(config-if)#ip add 10.1.2.3 255.255.255.0
R3(config-if)#no sh
R3(config-if)#no shutdown
R3(config-if)#int loop 3
R3(config-if)#ip add 3.3.3.3 255.255.255.255
R3(config)#router ospf 110
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0
R3(config-router)#network 10.1.2.0 0.0.0.255 area 0

2. Virtual link and its configuration

2.1 virtual link overview

Virtual link refers to a link connected to the backbone area through a non backbone area. Virtual links are mainly used in the following two cases
1. Connect an area to the backbone area through a non backbone area
2. Connect a non backbone area to some areas on both sides of a segmented backbone area

2.1 application occasions and functions of virtual link

Usage: when a non backbone area crosses a non backbone area

Function: help this non backbone area obtain the complete lsdb

2.2 virtual link command

Command: transfer area of non backbone area

R10:ospf

area 1

vlink-peer Opposite end router-id

R18:ospf

area 1

vlink-peer Opposite end router-id

Note: the virtual link can only help a non backbone region to cross the non backbone region. The virtual link belongs to the region 0display ospf vlink

2.3 rules and characteristics of configuring virtual links

1. The virtual link must be configured between two ABR routers
2. The total transmission area cannot be a terminal area
3. The stability of the virtual link depends on the stability of the area it passes through

2.4 create virtual link and configure bidirectional redistribution and end area

Router I
R1#conf t enter global mode
R1(config)#int f0/0 entering physical interface
R1(config-if)#ip add 10.1.1.1 255.255.255.0 configuring interface IP
R1(config-if)#no shutdown enable this interface
R1(config)#int loopback 0 enters loopback
R1(config-if)#ip add 1.1.1.1 255.255.255.255 configure loopback IP
R1(config)#router ospf 110 enables ospf processes
R1(config-router)#router-id 1.1.1.1 configuring routerid
R1(config-router)#network 10.1.1.0 0.0.0.255 area 1 declares that the direct network segment is in area 1
R1(config-router)#network 1.1.1.1 0.0.0.0 area 1 declares that the direct network segment is in area 1
R1(config-router)#area 1 stub configure end area
Router II
R2#conf t enter global mode
R2(config)#int f0/0 entering physical interface
R2(config-if)#ip add 10.1.1.2 255.255.255.0 configuring interface IP
R2(config-if)#no shutdown enable this interface
R2(config-if)#int f1/0 entering physical interface
R2(config-if)#ip add 10.1.2.2 255.255.255.0 configuring interface IP
R2(config-if)#no shutdown enable this interface
R2(config)#int loopback 0 enters loopback
R2(config-if)#ip add 2.2.2.2 255.255.255.255 configure loopback IP
R2(config)#router ospf 110 enable OSPF process
R2(config-router)#router-id 2.2.2.2 configuring routerid
R2(config-router)#network 10.1.1.0 0.0.0.255 area 1 declares that the direct network segment is in area 1
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0 declares that the direct network segment is in area 0
R2(config-router)#network 10.1.2.0 0.0.0.255 area 0 declares that the direct network segment is in area 0
R2(config-router)#Area 1 stub no summary
Router III
R3#conf t enter global mode
R3(config)#int f0/0 entering physical interface
R3(config-if)#ip add 10.1.2.3 255.255.255.0 configuring interface IP
R3(config-if)#no shutdown enable this interface
R3(config-if)#int f1/0 entering physical interface
R3(config-if)#ip add 10.1.3.3 255.255.255.0 configuring interface IP
R3(config-if)#no shutdown enable this interface
R3(config)#int loopback 0 enters loopback
R3(config-if)#ip add 3.3.3.3 255.255.255.255 configure loopback IP
R3(config)#router ospf 110 enables ospf processes
R3(config-router)#router-id 3.3.3.3 configuring routerid
R3(config-router)#network 10.1.2.0 0.0.0.255 area 0 declares that the direct network segment is in area 0
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0 declares that the direct network segment is in area 0
R3(config-router)#network 10.1.3.0 0.0.0.255 area 2 declares that the direct network segment is in area 2
R3(config-router)#area 2 virtual-link 4.4.4.4 configure the virtual link and specify the routerid of the ABR to pass through
Router IV
R4#conf t enter global mode
R4(config)#int f0/0 entering physical interface
R4(config-if)#ip add 10.1.3.4 255.255.255.0 configure this interface IP
R4(config-if)#no shutdown enable this interface
R4(config-if)#int f1/0 enters this interface
R4(config-if)#ip add 10.1.4.3 255.255.255.0 configure this interface IP
R4(config-if)#no shutdown enable this interface
R4(config)#int loopback 0 enters loopback
R4(config-if)#ip add 4.4.4.4 255.255.255.255 configure loopback IP
R4(config-router)#router-id 4.4.4.4 configuring routerid
R4(config-router)#network 10.1.3.0 0.0.0.255 area 2 declares that the direct network segment is in area 2
R4(config-router)#network 4.4.4.4 0.0.0.0 area 2 declares that the direct network segment is in area 2
R4(config-router)#network 10.1.4.0 0.0.0.255 area 3 declares that the direct network segment is in area 3
R4(config)#router ospf 110 starts the ospf process
R4(config-router)#area 2 virtual-link 3.3.3.3 configure the virtual link and specify the routerid of the ABR to pass through
R4(config-router)#redistribute rip subnet0
R4(config)#router rip enable rip protocol
R4(config-router)#redistribute ospf 110 metric 0
 Bidirectional redistribution
R4(config-router)#The non pure terminal area of area 3 nssa configuration area 3 needs to be configured on abr
Router V
R5#conf t enter global mode
R5(config)#int f0/0 enters this interface
R5(config-if)#ip add 10.1.4.5 255.255.255.0 configure this interface IP
R5(config-if)#no shutdown enable this interface
RW5(config-if)#Exit exit
R5(config)#int loopback 0 enters loopback
R5(config-if)#ip add 5.5.5.5 255.255.255.255 configure loopback IP
R5(config)#router ospf 110 starts the ospf process
R5(config-router)#router-id 5.5.5.5 configuring router id
R5(config-router)#network 10.1.4.0 0.0.0.255 area 3 declares that the direct network segment is in area 3
R5(config-router)#network 5.5.5.5 0.0.0.0 area 3 declares that the direct network segment is in area 3
Router VI
R6(config)#int f0/0 entering physical interface
R6(config-if)#ip add 192.168.10.6 255.255.255.0 configuring interface IP
R6(config-if)#no shutdown enable this interface
R6(config)#int loopback 0 enters loopback
R6(config-if)#ip add 6.6.6.6 255.255.255.255 configure loopback IP
R6(config)#router rip enable rip protocol
R6(config-router)#Version 2 enables version 2
R6(config-router)#network 6.0.0.0 declare the direct network segment in the main class mode
R6(config-router)#network 192.168.10.0 declare the direct network segment in the form of main class
 After configuration, check that the non direct route in the route table is replaced by the default route

Keywords: network server p2p

Added by non_zero on Sat, 18 Dec 2021 09:07:08 +0200